Gnuradio PDF

When installing GNURadio from the Ettus Research prebuilt packages, I have run into the following issue on some machines.  When starting gnuradio-companion, you get the error "Cannot import gnuradio" and advising you to check your PYTHONPATH and LD_LIBARY_CONFIG environment variables.  Well assuming those are OK and you've run ldconfig, try this:

 

Manually attempt to import something from the python commandline:

python -c "from gnuradio import gr" 


This will give a much more verbose reason as to why the import is failing.  In my case it was missing liblog4cpp.so.5.  I installed the liblog4cpp packages and that fixed the issue.